Przejdź do głównej treści
MedCalc

Jak wprowadzać dane

Dane dla poszczególnych zmiennych wprowadza się w różnych kolumnach arkusza kalkulacyjnego. Wszystkie dane jednego pacjenta lub przypadku wprowadza się w jednym wierszu arkusza. W górnym wierszu kolumn możesz wpisać nazwy zmiennych.

  • Nazwa zmiennej nie powinna zawierać spacji. W razie potrzeby możesz rozdzielać wyrazy znakiem podkreślenia _, np. GRADE_A. W nazwie zmiennej nie można także używać następujących znaków:

    - + / * = < > # & @ $ | ^ : , ; . ( ) ' " [ ] { }

  • Ponadto nazwa zmiennej nie może być liczbą ani zaczynać się od cyfry i musi się różnić od słów zastrzeżonych, takich jak TRUE, FALSE, ROW i COLUMN.
  • Nazwa zmiennej nie powinna też być taka sama jak adres komórki arkusza, np. A1, S1, AB35, IL6 itp.

Aby wpisać nazwę zmiennej LENGTH w górnym wierszu kolumny A, najpierw umieść wskaźnik myszy na tej komórce i kliknij lewym przyciskiem myszy. Kursor komórki znajduje się teraz w tej komórce i możesz wpisać nazwę zmiennej na klawiaturze. Następnie naciśnij klawisz Strzałka w dół, aby zapisać nazwę w pamięci komputera i przenieść kursor komórki do komórki A1. W tej komórce możesz teraz wpisać pierwszą wartość zmiennej LENGTH, 171, a następnie nacisnąć klawisz Strzałka w dół, aby przejść do następnej komórki.

Zmiana zawartości komórki

Jeśli chcesz zmienić, czyli edytować, zawartość komórki, umieść na niej kursor komórki i naciśnij klawisz funkcyjny F2. Możesz teraz przesuwać kursor w tekście komórki za pomocą klawiszy strzałek Strzałka w lewo i Strzałka w prawo i wprowadzić potrzebne zmiany. Po wprowadzeniu zmian naciśnij klawisz Enter lub przenieś kursor komórki do innej komórki, aby zapisać nową zawartość komórki w pamięci.

Zapisywanie danych

Podczas wprowadzania danych musisz od czasu do czasu zapisywać je na dysku. Gdy zapisujesz plik po raz pierwszy, kliknij Zapisz jako w menu Plik, a następnie wpisz nazwę pliku w oknie wyboru pliku opisanym w innym miejscu. Po nadaniu nazwy plikowi danych możesz klikać Zapisz w menu Plik, aby zapisywać dane pod tą samą nazwą pliku.

Formatowanie danych

Program automatycznie formatuje wprowadzane liczby zgodnie z liczbą miejsc po przecinku wybraną w oknie dialogowym Formatuj arkusz.

Dane
A1
171
 ABC
LENGTHWEIGHT
117166
217461.5
318282
417280
517075.5

Powyższy obraz przedstawia liczby wymierne, w których separatorem dziesiętnym jest kropka (np. 75.5). W większości krajów europejskich separatorem dziesiętnym jest przecinek i liczba 75.5 jest wyświetlana jako 75,5.

Separator dziesiętny jest opcją w Panelu sterowania systemu Windows i MedCalc domyślnie używa tego ustawienia. Działa to tak samo jak np. w programie Excel.

Separator dziesiętny używany przez MedCalc możesz jednak zmienić w panelu Opcje (karta Ustawienia regionalne).

Jeśli chcesz ustawić inną liczbę miejsc po przecinku dla określonej kolumny, kliknij Arkusz kalkulacyjny w menu Format i wpisz nową liczbę miejsc po przecinku na karcie Kolumna. W tym oknie dialogowym możesz również ustawić inną szerokość kolumny. Możesz także określić, że dana kolumna zawiera tekst, daty lub godziny (opcja „Format tekstowy”).

Formatowanie kolumny arkusza kalkulacyjnego

Zmienne

Zmienna może być kategorialna albo liczbowa. Zmienne kategorialne mogą zawierać dane liczbowe lub alfanumeryczne (ciągi znaków). Zmienna liczbowa zawsze zawiera dane liczbowe.

Zmienna kategorialna, czyli jakościowa

Dane kategorialne, czyli jakościowe, można wprowadzać jako liczby lub jako tekstowe ciągi znaków. Ciąg znaków składa się z jednego lub kilku znaków alfanumerycznych umieszczonych w cudzysłowie. Program traktuje jako ciąg znaków każde wyrażenie, którego nie można zinterpretować jako liczby, nawet jeśli nie jest ujęte w cudzysłów, np. "Green", yellow, "10". Rozróżnia się dane nominalne i porządkowe:

  • Dane nominalne: klasyfikacja bez oczywistego porządku, np. grupa krwi, mężczyzna/kobieta.
  • Dane porządkowe: uporządkowane dane kategorialne, np. stopień zaawansowania endometriozy, stopień żylaków powrózka nasiennego.

Zmienną, która może przyjmować tylko 2 wartości, nazywa się także zmienną dychotomiczną, np. w ciąży/nie w ciąży, mężczyzna/kobieta.

W MedCalc często warto kodować dane kategorialne wartościami liczbowymi: 0 i 1 albo 1 2 3 4 itd.

Zmienna liczbowa, czyli ilościowa

Zmienna liczbowa składa się z liczb, np. 0, 25 lub 3,258, albo z wyrażeń, które można zinterpretować jako liczbę, np. LOG(25) lub SQRT(VAR1), gdzie VAR1 jest nazwą zmiennej zawierającej dane liczbowe.

Dane liczbowe mogą być ciągłe albo dyskretne.

Dane ciągłe: liczby, które teoretycznie mogą przyjąć dowolną wartość między dwiema danymi wartościami; zwykle są to pomiary, np. wzrost osoby.

Dane dyskretne: dane, które nie są ciągłe (i mogą przyjmować ograniczoną liczbę wartości), zwykle zliczenia, np. liczba dzieci w rodzinie.

Zmienną liczbową możesz łatwo przekształcić w zmienną kategorialną za pomocą funkcji arkusza CATEGORISE lub IF (funkcja jeśli-to-w przeciwnym razie).

Zobacz także